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Introduction
eqWave displays digital waveform files created by the Yerilla and Kelunji series of seismic recorders, and 
files extracted from other sources.

The Formats that can be read are:

• PC-SUDS.

• Kelunji Classic KA1 & KA2.

• Yerilla.

• GSE.

• CSS.

• Tabulated Text.

• Kelunji Bulk files.

• Files that have been compressed using Gzip (ie, have a .gz extension) are automatically 
decompressed.

You can use eqWave to:

• Load and view waveform data.

• View  waveforms from multiple stations in a single file or waveforms from a sequence of files.

• Split bulk waveform files into individual files.

• Merge multiple waveform files into one file.

• Zoom, pan, and scale the display.

• Filter the waveform data using high and low band pass filters.

• Compute the Fourier transform of a selected segment of waveform.

• Display state of health information about a seismograph site at a particular instant in time.

• Pick the arrival times (e.g. P, S and data such as the finish time of the event, maximum amplitude 
and frequency).

• Save the original or filtered waveform data and the picked arrival times.

• Estimate local Richter magnitude.
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Annotated eqWave Window
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eqWave Menus at a Glance

Menu Menu Item Description

File Open Open a seismogram or bulk file, in a new window if a file is already open.

Open & Close Open a seismogram and closing the currently open file.

Merge Merge two or more files together.

Save Save the current file.

Save As Save the current file specifying its name and format.

Save Fourier Save the Fourier values in text formated file.

Next Load the next (by date) seismogram in the current working directory.

Back Load the previous (by date) seismogram in the current working directory.

Print Print the current seismogram.

Close Close the current seismogram.

Quit Quit eqWave.

Edit Copy Arrivals Copy any arrival picks for pasting into eqFocus.

Clip Remove (clip) minimised waveforms.

Remove Spike Remove spikes from the seismogram.

16 to 32 bit fix Some early model Kelunji  recorders cliped signal data at 16 bits, this 
option attempts to reconstruct this data.

Send Set Path Set the folder where arrivals will be saved using the Send Arrivals to 
Folder option.

Send Arrivals to Folder Saves a PC-SUDS formated file containing only arrival information.

Display Zero Correction Centre displayed waveforms about the Zero axis.

Amplitude Grouping Display some or all waveforms at the same amplitude range by:
• All
• Site
• Individual

Acceleration Units Display acceleration channel units as m/s/s or g.

Pressure Units Display pressure channel units as dB or Pa (blast monitoring only)

Show S-P Show S-P arrival  times.

Sort by Site code Display the waveforms in order of site code (alphabetical).

Sort by P Arrival Display the waveforms in order of P arrival times.

Set up STA/LTA... Set up the STA/LTA ratio which is displayed as the amber line for each 
waveform.

Display Vector Sum Display the vector sum for a selected channel group.

Channels Properties Open the Properties dialogue window for the selected channel 

All Show all channels from all sites contained in the current file.

Vertical Only show vertical channels from all sites in the current file.

Site List The site code for sites contained within the current file are listed here. 
Selecting a particular site code shows only the waveforms from that site.

Magnitude Estimate ML If there is sufficient information (recorder response, P, S, and MAX 
arrivals) open the Estimate Magnitude dialogue window to display an 
estimate of ML magnitude.

Help About Show the version of eqWave and JRE being used.
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View the waveforms

Specify the waveform file

You can open a single waveform data file, scan through a series of waveform files, split a bulk waveform file 
and merge a number of waveform files.

Opening a waveform file
Select Open from the File menu.

• Locate and select the name of the file that you want to open. eqWave displays the waveform file. 
Alternatively, the file can be opened by dragging and dropping the file icon onto eqWave.

Displaying a waveform file
To open in a new window

Select Open from the File menu, then locate and select the waveform file.

eqWave displays the waveform/s in a new window.

To open in the current window

Select Close & Open from the File menu, then locate and select the new waveform file.

eqWave replaces the waveform/s in the current window with the newly selected waveform.

To scan through a sequence of waveform files

eqWave can identify the next or previous waveform file in the sequence based on the file name date stamp.

To scan forwards through the sequence select Next (Ctrl+N) from the File menu, or click the  icon on the 
tool bar (specifying a site code in the File Filter field only load the files for the specified site in the current 
directory).

To scan backwards select Back (Ctrl+B) from the File menu, or click the   icon on the tool bar.
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Extracting waveform files from a Bulk file
A bulk file is generated by Kelunji classic and D-series seismographs manufactured by ES&S

• Select Open from the File menu.

• Locate and select the name of the Bulk file that you want to open.

• A list of the waveform files located within the bulk file is displayed.

The Alt Button

• If the Bulk file seems corrupted and cannot list all its files, then click on the “Alt” button.  This will use 
a different technique for determining the files contained in the Bulk file. 

• elect the files you wish to open. 

• Select one file, or choose multiple files by using the following key-mouse combinations.

Key Combination Files Selected

Left-click One individual file

Shift-click A range of (consecutively listed) files

Ctrl-click Multiple individual files

• Click EXTRACT

• Use the Choose Folder dialogue box to locate and specify the folder to store the extracted 
waveforms.

• Click the window's close box
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Merging waveform files
• With an existing waveform on display, select Merge from the File menu.

• Locate and select the name of the file that you wish to include in the current display. Click the Open 
button.

• eqWave will merge the files on one display, provided the waveforms are less than 60 minutes apart.

• Alternatively, hold down the Ctrl key while dragging the file to be merged and dropping it onto the 
current window.

The Fourier Display Panel

To access the Fourier Display Panel, drag the bottom edge of the Window Panel upwards.

The Fourier Display can be used to determine the frequency content and dominant frequency of the 
waveform or of a section of the waveform.
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Adjusting the display
You may want to adjust the waveform display so that you can more easily pick arrivals. Adjustments include:

• Scan the waveform to find events

• Adjusting the displayed Timespan

• Selectively hide channels that are not of interest

• Increasing or decreasing the waveform display amplitude

The eqWave control panel contains a number of buttons that enable you to adjust the waveform display.

Changing the display amplitude (vertical axis scale)
You can increase or decrease the vertical size of the waveform display amplitude by adjusting the scale on 
the vertical axis.

Do this after you have made all other adjustments to the display.

NOTE: Each time you make other adjustments to the display, such as minimize a channel, zoom in, or apply 
a filter, eqWave recalculates the peak amplitude and adjusts the scale of the vertical axis accordingly.

To increase the display size of the waveform

Click the Increase Wave Size button    or type: Alt - Up Arrow

eqWave reduces the amplitude value of the of the vertical axis, and plots the expanded waveform.

To decrease the display size of the waveform

Click the Decrease Wave Size button    or type: Alt – Down Arrow

eqWave increases the amplitude value of the vertical axis, and plots the contracted waveform.

Amplitude Grouping
The Amplitude Grouping options are found under the Display menu and allow for some or all waveforms to 
be displayed at the same amplitude.

Display All waveforms at the same amplitude

• In the Display menu, under Amplitude Grouping, select All. 

• eqWave displays all waveforms at a scale equal to that of the largest waveform amplitude in the 
original display.

Site

• To display only those waveform channels from the same site at the same scale, chose Site from the 
Display menu.

Individual

• To display or return waveforms to their original amplitude scale, choose Individual from the Display 
menu.
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Zooming in on a time interval

Use the zoom buttons   on the control panel to zoom in or out.

When you zoom in or out, eqWave scans all channels to identify the maximum and minimum/peak amplitude 
for the specified time interval. eqWave adjusts the vertical scale of all channels to suit this peak amplitude.

To zoom in (enlarge the display)

Click the Zoom In button   or type: Alt – Page Up

Each time you click this button, eqWave will halve the time span, and redisplay the channels.  The zoom will 
be centred about the current cursor position.

To zoom out (reduce the display)

Click the Zoom Out button  or type: Alt – Page Down

Each time you click this button, eqWave will double the time span and redisplay the channels.  The zoom will 
be centred about the current cursor position.

To zoom in on a specific time interval

• Hold down the right mouse button and highlight the required time interval. Alternatively, hold down 
the Control key and drag over the area of interest.

• Click the Zoom In button

To restore the display to the default scale

Click the Default Time span button   or type: Alt - Enter

Panning the display to view earlier or later time intervals
To view an earlier time interval 

Click the Move Time Back button  

The waveform will scroll to the right to display an earlier section of the waveform.

To view a later time interval

Click the Move Time Forward button   

The waveform will scroll to the left to display a later section of the waveform.

Displaying and hiding waveforms
To view a single channel

Click the Maximize Wave button [+] to expand the waveform of the selected channel to fill the waveform 
display.

Click the Minimize Wave button [-] to return to the multi-channel display.

To hide individual channels

Click the Minimize Wave button [-] to hide the waveform of the selected channel.

Click the Maximize button [+] to redisplay the channel's hidden waveform.
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To Permanently Remove unwanted channels

Select Clip from the Edit menu.

To sort the display order of channels

Use the Display menu to sort the order of channels alphabetically by  sitecode or in order of the P arrival 
time.

To: Use:

To view vertical channels only Select Vertical from the Channels Menu.

To view all channels from one site Select a Site Code from the Channels Menu.

To view all channels Select All to display all channels.

Zero Correction
The purpose of Zero Correction is to centre displayed waveforms about the Zero axis. This is done by finding 
the average of the waveform sample values, and then adjusting the waveform vertically by the result.

• Select None for no Zero Correction

• For Zero Correction calculated using only the waveform currently displayed, select Displayed in the 
waveform display panel.

• For Zero Correction calculated using the entire waveform, even if only a portion is displayed, select 
All.
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Setting STA/LTA
The STA/LTA ratio

The STA/LTA (short term average/long term average) ratio can be displayed as a red line on the waveforms, 
as an aid to picking arrivals, and examining how changes in setting would affect triggering in eqLogger or the 
seismograph.

The graph is drawn with the value 0 at the base of channel, and the threshold value at the centre line.

Setting the STA/LTA ratio

To display the STA/LTA ratio line, select Setup STA/LTA in the Display menu and tick On in the STA LTA 
window. 

• The STA is calculated by getting the average of the zero corrected, positive amplitudes of samples 
within the window time, in seconds. 

• For example, entering 1.5 will create a 1.5 second STA window time. The default is 2 seconds.

• The LTA is calculated in the same way as STA. Default = 20 seconds.

• The STA/LTA ratio is calculated by dividing STA by LTA.

• To prevent very high STA/LTA ratios when LTA is small, a damping number can be added to LTA.

• Set the STA/LTA ratio value at which a trigger is declared by entering a ratio in the Threshold value. 

• The waveform can be pre-filtered with band pass filter values before calculating the STA/LTA Ratio.

A STA/LTA ratio trace can be displayed using the recorder settings (for echo and echo pro recorders only) by 

be clicking on the  button to the left of the waveform. 
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Processing waveform data

Viewing waveform data 
Click on a waveform.

eqWave displays a vertical line across the waveforms to mark your cursor position, the channel name, and 
the time and amplitude at that point

 

Arrival times

Picking Arrival Times
Move the cursor over the waveform and click on the desired site and time.

Select Polarity and Onset from the pull down menu.

Click the button that corresponds to the arrival type you want to pick or enter another phase and press the 
‘Other’ button.

eqWave displays 

• A line on the waveform representing the selected arrival

• Station, arrival type and time below the time axis

• Time, station and arrival type in the Arrivals List Panel

• S-P times, when both P and S arrivals are picked, and when the Show S-P option in the Display 
menu has been selected

• The duration time, if both P and F are picked

Deleting Arrivals
• Open up the Arrival List Panel.

• Select an Arrival in the list.

• Click the Delete Button.
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Filtering waveforms

Applying band pass filters
The band pass filter removes data outside the specified frequency range. This can remove the effect of 
spikes or noise in the data.

Click on a Channel that you wish to filter, select the High and Low Pass Frequencies then click either the 
Chan, Site or All button (Reset removes the filter), to filter either the single Channel, all the Channels for 
that Site, or All the Channels.

The filter is performed using a Fourier Transform, setting the unwanted frequencies to a value of zero, then 
transforming back into a time series.

The filter values are stored in the PC-SUDS file when saved.  The samples in the waveform are not changed, 
so that it can be restored to its unfiltered state.

Setting waveform properties
To change many of the basic attributes of a waveform, such as it's name and start date, 

Click on the wave in the Waveform Display Channel.

Select Properties from the Channels menu.
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Estimating Magnitudes
The Kelunji Echo and EchoPro recorders save response information with the PC-SUDS files they create 
(both triggered and continuous files). With this information it is possible to calculate an estimate of  ML (local 
Richter) magnitudes.

To estimate the ML magnitude you will need to at least select a maximum amplitude and frequency pick (a 
MAX pick), P arrival and S arrival (to estimate distance):

• Select the vertical channel of the waveform to use to calculate the magnitude estimate.

• Pick a P arrival

• Pick an S arrival

• Pick a MAX arrival

• Open the Estimate magnitude  dialogue from the Magnitude menu:

• If necessary you can  specify a different distance and the magnitude will by recalculated with the 
new distance as you type it.

• Uses 8m/s to calculate distance which may or may not be applicable to your geological setting.
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Vector Sum Plot
The Kelunji Echo and EchoPro recorders save response information with the PC-SUDS files they create 
(both triggered and continuous files). With this information it is possible to calculate a vector sum using the 
three components from the transducer:

To create a vector sum plot:

• Select a waveform within the channel group of interest.

• Select Display Vector Sun  from the Display menu to display the vector sum window.
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Save and Print 

Save options
eqWave allows waveform data and arrivals to be saved in a number of formats and for use in other 
programs.

 

To save waveform files
Select Save from the File menu.

Files can be saved as:

• Old PC-SUDS 1.4 format.

• PC-SUDS 1.5.1 format, which includes added fields for naming sites and channels

• Text Table format, which is useful for importing into a Spreadsheet.

• The text file contains comments explaining the meaning of the header information, data 
values are in recorder counts.

The Filename can be automatically formatted according to 2 conventions:

• SRC format, e.g, 2005-09-22 0351 10 GVL.dmx

• GA format, e.g., GVL05265_035110.dmx
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To save the Fourier data
The Fourier data can be saved by selecting Save Fourier in the File menu.

eqWave saves the Fourier data as a tabulated text file, allowing easy importing into a spreadsheet.

Printing from eqWave
With the desired waveform on display, select Print from the File menu.

Exporting saved data

Writing files of arrivals to another directory
You may want to store picked arrivals in a specific directory ready for another program to read. The arrivals 
are stored in PC-SUDS format (no waveform data, only arrival information).

To set the path of the directory
• Select Set Path from the Send menu.

• Use the Select Directory file dialogue to locate the directory.

• Click Select Directory.

To save the arrival data in the directory
• Select Send Arrivals To Folder from the Send menu. 

• Locate the directory

• Click OK. eqWave displays an Arrivals Sent information box.

Exporting Arrivals to eqFocus
Arrivals can be copied and pasted into eqFocus by selecting Copy Arrivals from the Edit menu, then in 
eqFocus select Paste from the Edit menu of eqFocus. 
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Quitting eqWave

Closing the display window
To close the current window select Close from the File menu. 

eqWave closes the display but remains active.

Quitting eqWave
Select Quit from the File Menu, or select Close when the current window is empty.

eqWave will display a Quit? dialogue box. 

Select Yes to quit, or select No if you want to continue.
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